kernel: bump 5.10 to 5.10.137

Removed following upstreamed patch:

 * bcm53xx: 081-next-ARM_dts_BCM53015-add-mr26.patch

All other patches automagically rebased.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit d1163fd13f6498826d202f0b58cedf32d7891d52)
This commit is contained in:
Petr Štetiar 2022-08-22 22:45:53 +02:00
parent a901a13505
commit 4209c33ae2
22 changed files with 38 additions and 38 deletions

View File

@ -1,2 +1,2 @@
LINUX_VERSION-5.10 = .136 LINUX_VERSION-5.10 = .137
LINUX_KERNEL_HASH-5.10.136 = 1c099d0d59e7d9f671dfc947e16891b7a3a45efd7dfcc6b1e55a194961e45159 LINUX_KERNEL_HASH-5.10.137 = c16bcd4d1453d7e645007d0a25270f52401331c7df81c364f57bde914e1616c8

View File

@ -9,7 +9,7 @@
struct fis_image_desc { struct fis_image_desc {
unsigned char name[16]; // Null terminated name unsigned char name[16]; // Null terminated name
uint32_t flash_base; // Address within FLASH of image uint32_t flash_base; // Address within FLASH of image
@@ -72,6 +74,7 @@ static int parse_redboot_partitions(stru @@ -73,6 +75,7 @@ static int parse_redboot_partitions(stru
const struct mtd_partition **pparts, const struct mtd_partition **pparts,
struct mtd_part_parser_data *data) struct mtd_part_parser_data *data)
{ {
@ -17,7 +17,7 @@
int nrparts = 0; int nrparts = 0;
struct fis_image_desc *buf; struct fis_image_desc *buf;
struct mtd_partition *parts; struct mtd_partition *parts;
@@ -239,14 +242,15 @@ static int parse_redboot_partitions(stru @@ -240,14 +243,15 @@ static int parse_redboot_partitions(stru
} }
} }
#endif #endif
@ -35,7 +35,7 @@
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
if (nulllen > 0) { if (nulllen > 0) {
strcpy(nullname, nullstring); strcpy(nullname, nullstring);
@@ -265,6 +269,8 @@ static int parse_redboot_partitions(stru @@ -266,6 +270,8 @@ static int parse_redboot_partitions(stru
} }
#endif #endif
for ( ; i<nrparts; i++) { for ( ; i<nrparts; i++) {
@ -44,7 +44,7 @@
parts[i].size = fl->img->size; parts[i].size = fl->img->size;
parts[i].offset = fl->img->flash_base; parts[i].offset = fl->img->flash_base;
parts[i].name = names; parts[i].name = names;
@@ -298,6 +304,13 @@ static int parse_redboot_partitions(stru @@ -299,6 +305,13 @@ static int parse_redboot_partitions(stru
fl = fl->next; fl = fl->next;
kfree(tmp_fl); kfree(tmp_fl);
} }

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/parsers/redboot.c --- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c +++ b/drivers/mtd/parsers/redboot.c
@@ -93,12 +93,18 @@ static int parse_redboot_partitions(stru @@ -94,12 +94,18 @@ static int parse_redboot_partitions(stru
parse_redboot_of(master); parse_redboot_of(master);
@ -19,7 +19,7 @@
return -EIO; return -EIO;
} }
offset -= master->erasesize; offset -= master->erasesize;
@@ -111,10 +117,6 @@ static int parse_redboot_partitions(stru @@ -112,10 +118,6 @@ static int parse_redboot_partitions(stru
goto nogood; goto nogood;
} }
} }
@ -30,7 +30,7 @@
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n", printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
master->name, offset); master->name, offset);
@@ -187,6 +189,11 @@ static int parse_redboot_partitions(stru @@ -188,6 +190,11 @@ static int parse_redboot_partitions(stru
} }
if (i == numslots) { if (i == numslots) {
/* Didn't find it */ /* Didn't find it */

View File

@ -1,6 +1,6 @@
--- a/drivers/mtd/parsers/redboot.c --- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c +++ b/drivers/mtd/parsers/redboot.c
@@ -70,6 +70,22 @@ static void parse_redboot_of(struct mtd_ @@ -71,6 +71,22 @@ static void parse_redboot_of(struct mtd_
directory = dirblock; directory = dirblock;
} }
@ -23,7 +23,7 @@
static int parse_redboot_partitions(struct mtd_info *master, static int parse_redboot_partitions(struct mtd_info *master,
const struct mtd_partition **pparts, const struct mtd_partition **pparts,
struct mtd_part_parser_data *data) struct mtd_part_parser_data *data)
@@ -86,6 +102,7 @@ static int parse_redboot_partitions(stru @@ -87,6 +103,7 @@ static int parse_redboot_partitions(stru
int namelen = 0; int namelen = 0;
int nulllen = 0; int nulllen = 0;
int numslots; int numslots;
@ -31,7 +31,7 @@
unsigned long offset; unsigned long offset;
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
static char nullstring[] = "unallocated"; static char nullstring[] = "unallocated";
@@ -200,7 +217,10 @@ static int parse_redboot_partitions(stru @@ -201,7 +218,10 @@ static int parse_redboot_partitions(stru
goto out; goto out;
} }
@ -43,7 +43,7 @@
struct fis_list *new_fl, **prev; struct fis_list *new_fl, **prev;
if (buf[i].name[0] == 0xff) { if (buf[i].name[0] == 0xff) {
@@ -276,12 +296,13 @@ static int parse_redboot_partitions(stru @@ -277,12 +297,13 @@ static int parse_redboot_partitions(stru
} }
#endif #endif
for ( ; i<nrparts; i++) { for ( ; i<nrparts; i++) {
@ -59,7 +59,7 @@
strcpy(names, fl->img->name); strcpy(names, fl->img->name);
#ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY #ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
if (!memcmp(names, "RedBoot", 8) || if (!memcmp(names, "RedBoot", 8) ||
@@ -311,7 +332,9 @@ static int parse_redboot_partitions(stru @@ -312,7 +333,9 @@ static int parse_redboot_partitions(stru
fl = fl->next; fl = fl->next;
kfree(tmp_fl); kfree(tmp_fl);
} }

View File

@ -35,7 +35,7 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -158,6 +158,10 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \ @@ -159,6 +159,10 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
bcm958525xmc.dtb \ bcm958525xmc.dtb \
bcm958622hr.dtb \ bcm958622hr.dtb \
bcm958623hr.dtb \ bcm958623hr.dtb \

View File

@ -31,7 +31,7 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -162,6 +162,8 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \ @@ -163,6 +163,8 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
bcm958625-meraki-mx64-a0.dtb \ bcm958625-meraki-mx64-a0.dtb \
bcm958625-meraki-mx64w.dtb \ bcm958625-meraki-mx64w.dtb \
bcm958625-meraki-mx64w-a0.dtb \ bcm958625-meraki-mx64w-a0.dtb \

View File

@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
if (ret < 0) { if (ret < 0) {
pr_err("%s: failed to add hogs for %pOF\n", __func__, pr_err("%s: failed to add hogs for %pOF\n", __func__,
rd->dn); rd->dn);
@@ -1035,9 +1045,11 @@ int of_gpiochip_add(struct gpio_chip *ch @@ -1037,9 +1047,11 @@ int of_gpiochip_add(struct gpio_chip *ch
of_node_get(chip->of_node); of_node_get(chip->of_node);

View File

@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
.width = 2, .width = 2,
--- a/drivers/mtd/parsers/redboot.c --- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c +++ b/drivers/mtd/parsers/redboot.c
@@ -84,6 +84,7 @@ static int parse_redboot_partitions(stru @@ -85,6 +85,7 @@ static int parse_redboot_partitions(stru
int nulllen = 0; int nulllen = 0;
int numslots; int numslots;
unsigned long offset; unsigned long offset;
@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
static char nullstring[] = "unallocated"; static char nullstring[] = "unallocated";
#endif #endif
@@ -190,6 +191,16 @@ static int parse_redboot_partitions(stru @@ -191,6 +192,16 @@ static int parse_redboot_partitions(stru
goto out; goto out;
} }
@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
for (i = 0; i < numslots; i++) { for (i = 0; i < numslots; i++) {
struct fis_list *new_fl, **prev; struct fis_list *new_fl, **prev;
@@ -210,10 +221,10 @@ static int parse_redboot_partitions(stru @@ -211,10 +222,10 @@ static int parse_redboot_partitions(stru
goto out; goto out;
} }
new_fl->img = &buf[i]; new_fl->img = &buf[i];

View File

@ -34,7 +34,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
struct nft_set *set; struct nft_set *set;
--- a/net/netfilter/nf_tables_api.c --- a/net/netfilter/nf_tables_api.c
+++ b/net/netfilter/nf_tables_api.c +++ b/net/netfilter/nf_tables_api.c
@@ -892,6 +892,12 @@ static void nf_tables_table_disable(stru @@ -893,6 +893,12 @@ static void nf_tables_table_disable(stru
nft_table_disable(net, table, 0); nft_table_disable(net, table, 0);
} }
@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
static int nf_tables_updtable(struct nft_ctx *ctx) static int nf_tables_updtable(struct nft_ctx *ctx)
{ {
struct nft_trans *trans; struct nft_trans *trans;
@@ -915,19 +921,17 @@ static int nf_tables_updtable(struct nft @@ -916,19 +922,17 @@ static int nf_tables_updtable(struct nft
if ((flags & NFT_TABLE_F_DORMANT) && if ((flags & NFT_TABLE_F_DORMANT) &&
!(ctx->table->flags & NFT_TABLE_F_DORMANT)) { !(ctx->table->flags & NFT_TABLE_F_DORMANT)) {
@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
nft_trans_table_update(trans) = true; nft_trans_table_update(trans) = true;
list_add_tail(&trans->list, &ctx->net->nft.commit_list); list_add_tail(&trans->list, &ctx->net->nft.commit_list);
return 0; return 0;
@@ -7923,11 +7927,10 @@ static int nf_tables_commit(struct net * @@ -7931,11 +7935,10 @@ static int nf_tables_commit(struct net *
switch (trans->msg_type) { switch (trans->msg_type) {
case NFT_MSG_NEWTABLE: case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) { if (nft_trans_table_update(trans)) {
@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
} else { } else {
nft_clear(net, trans->ctx.table); nft_clear(net, trans->ctx.table);
} }
@@ -8140,11 +8143,9 @@ static int __nf_tables_abort(struct net @@ -8148,11 +8151,9 @@ static int __nf_tables_abort(struct net
switch (trans->msg_type) { switch (trans->msg_type) {
case NFT_MSG_NEWTABLE: case NFT_MSG_NEWTABLE:
if (nft_trans_table_update(trans)) { if (nft_trans_table_update(trans)) {

View File

@ -15,7 +15,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include "gpiolib.h" #include "gpiolib.h"
#include "gpiolib-of.h" #include "gpiolib-of.h"
@@ -1044,3 +1046,72 @@ void of_gpiochip_remove(struct gpio_chip @@ -1046,3 +1048,72 @@ void of_gpiochip_remove(struct gpio_chip
{ {
of_node_put(chip->of_node); of_node_put(chip->of_node);
} }

View File

@ -72,7 +72,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+MODULE_LICENSE("GPL"); +MODULE_LICENSE("GPL");
--- a/kernel/sched/core.c --- a/kernel/sched/core.c
+++ b/kernel/sched/core.c +++ b/kernel/sched/core.c
@@ -3066,6 +3066,7 @@ int wake_up_state(struct task_struct *p, @@ -3071,6 +3071,7 @@ int wake_up_state(struct task_struct *p,
{ {
return try_to_wake_up(p, state, 0); return try_to_wake_up(p, state, 0);
} }

View File

@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
--- a/drivers/mtd/parsers/redboot.c --- a/drivers/mtd/parsers/redboot.c
+++ b/drivers/mtd/parsers/redboot.c +++ b/drivers/mtd/parsers/redboot.c
@@ -279,14 +279,21 @@ static int parse_redboot_partitions(stru @@ -280,14 +280,21 @@ static int parse_redboot_partitions(stru
#endif #endif
names += strlen(names)+1; names += strlen(names)+1;

View File

@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#endif /* __LINUX_USB_PCI_QUIRKS_H */ #endif /* __LINUX_USB_PCI_QUIRKS_H */
--- a/include/linux/usb/hcd.h --- a/include/linux/usb/hcd.h
+++ b/include/linux/usb/hcd.h +++ b/include/linux/usb/hcd.h
@@ -486,7 +486,14 @@ extern int usb_hcd_pci_probe(struct pci_ @@ -487,7 +487,14 @@ extern int usb_hcd_pci_probe(struct pci_
extern void usb_hcd_pci_remove(struct pci_dev *dev); extern void usb_hcd_pci_remove(struct pci_dev *dev);
extern void usb_hcd_pci_shutdown(struct pci_dev *dev); extern void usb_hcd_pci_shutdown(struct pci_dev *dev);

View File

@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
--- a/drivers/soc/qcom/Kconfig --- a/drivers/soc/qcom/Kconfig
+++ b/drivers/soc/qcom/Kconfig +++ b/drivers/soc/qcom/Kconfig
@@ -189,6 +189,13 @@ config QCOM_SOCINFO @@ -190,6 +190,13 @@ config QCOM_SOCINFO
Say yes here to support the Qualcomm socinfo driver, providing Say yes here to support the Qualcomm socinfo driver, providing
information about the SoC to user space. information about the SoC to user space.

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -903,11 +903,75 @@ dtb-$(CONFIG_ARCH_QCOM) += \ @@ -904,11 +904,79 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-apq8074-dragonboard.dtb \ qcom-apq8074-dragonboard.dtb \
qcom-apq8084-ifc6540.dtb \ qcom-apq8084-ifc6540.dtb \
qcom-apq8084-mtp.dtb \ qcom-apq8084-mtp.dtb \

View File

@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -908,8 +908,30 @@ dtb-$(CONFIG_ARCH_QCOM) += \ @@ -909,8 +909,30 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-ipq4019-ap.dk04.1-c3.dtb \ qcom-ipq4019-ap.dk04.1-c3.dtb \
qcom-ipq4019-ap.dk07.1-c1.dtb \ qcom-ipq4019-ap.dk07.1-c1.dtb \
qcom-ipq4019-ap.dk07.1-c2.dtb \ qcom-ipq4019-ap.dk07.1-c2.dtb \

View File

@ -13,7 +13,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
--- a/drivers/clk/qcom/clk-krait.c --- a/drivers/clk/qcom/clk-krait.c
+++ b/drivers/clk/qcom/clk-krait.c +++ b/drivers/clk/qcom/clk-krait.c
@@ -68,7 +68,25 @@ static u8 krait_mux_get_parent(struct cl @@ -73,7 +73,25 @@ static u8 krait_mux_get_parent(struct cl
return clk_mux_val_to_index(hw, mux->parent_map, 0, sel); return clk_mux_val_to_index(hw, mux->parent_map, 0, sel);
} }
@ -39,7 +39,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
.set_parent = krait_mux_set_parent, .set_parent = krait_mux_set_parent,
.get_parent = krait_mux_get_parent, .get_parent = krait_mux_get_parent,
.determine_rate = __clk_mux_determine_rate_closest, .determine_rate = __clk_mux_determine_rate_closest,
@@ -79,8 +97,13 @@ EXPORT_SYMBOL_GPL(krait_mux_clk_ops); @@ -84,8 +102,13 @@ EXPORT_SYMBOL_GPL(krait_mux_clk_ops);
static long krait_div2_round_rate(struct clk_hw *hw, unsigned long rate, static long krait_div2_round_rate(struct clk_hw *hw, unsigned long rate,
unsigned long *parent_rate) unsigned long *parent_rate)
{ {

View File

@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
--- a/drivers/soc/qcom/Kconfig --- a/drivers/soc/qcom/Kconfig
+++ b/drivers/soc/qcom/Kconfig +++ b/drivers/soc/qcom/Kconfig
@@ -189,6 +189,13 @@ config QCOM_SOCINFO @@ -190,6 +190,13 @@ config QCOM_SOCINFO
Say yes here to support the Qualcomm socinfo driver, providing Say yes here to support the Qualcomm socinfo driver, providing
information about the SoC to user space. information about the SoC to user space.

View File

@ -5492,7 +5492,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
unsigned long type); unsigned long type);
--- a/include/linux/pci_ids.h --- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h +++ b/include/linux/pci_ids.h
@@ -1076,6 +1076,12 @@ @@ -1079,6 +1079,12 @@
#define PCI_DEVICE_ID_SGI_IOC3 0x0003 #define PCI_DEVICE_ID_SGI_IOC3 0x0003
#define PCI_DEVICE_ID_SGI_LITHIUM 0x1002 #define PCI_DEVICE_ID_SGI_LITHIUM 0x1002

View File

@ -14,7 +14,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -665,7 +665,8 @@ dtb-$(CONFIG_SOC_LS1021A) += \ @@ -666,7 +666,8 @@ dtb-$(CONFIG_SOC_LS1021A) += \
ls1021a-moxa-uc-8410a.dtb \ ls1021a-moxa-uc-8410a.dtb \
ls1021a-qds.dtb \ ls1021a-qds.dtb \
ls1021a-tsn.dtb \ ls1021a-tsn.dtb \

View File

@ -1,6 +1,6 @@
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -1203,6 +1203,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \ @@ -1204,6 +1204,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
sun8i-h3-orangepi-zero-plus2.dtb \ sun8i-h3-orangepi-zero-plus2.dtb \
sun8i-h3-rervision-dvk.dtb \ sun8i-h3-rervision-dvk.dtb \
sun8i-h3-emlid-neutis-n5h3-devboard.dtb \ sun8i-h3-emlid-neutis-n5h3-devboard.dtb \

View File

@ -27,7 +27,7 @@ Signed-off-by: Jayantajit Gogoi <jayanta.gogoi525@gmail.com>
- const: gemei,g9 - const: gemei,g9
--- a/arch/arm/boot/dts/Makefile --- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile
@@ -1193,6 +1193,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \ @@ -1194,6 +1194,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
sun8i-h3-nanopi-m1-plus.dtb \ sun8i-h3-nanopi-m1-plus.dtb \
sun8i-h3-nanopi-neo.dtb \ sun8i-h3-nanopi-neo.dtb \
sun8i-h3-nanopi-neo-air.dtb \ sun8i-h3-nanopi-neo-air.dtb \