rockchip: rename "Rock Pi 4" to "Rock Pi 4A"

Kernel has added the different variants of the Rock Pi 4 in commit
b5edb0467370 ("arm64: dts: rockchip: Mark rock-pi-4 as rock-pi-4a
dts"). The former Rock Pi 4 is now Rock Pi 4A.

For compatibility with kernel 5.4, this rename has been held back
so far. Having switched to kernel 5.10 now, we can finally apply
it in our tree as well.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
This commit is contained in:
Adrian Schmutzler 2021-10-02 17:36:48 +02:00
parent 0c2aa7c003
commit 91eed5d9fb
4 changed files with 5 additions and 34 deletions

View File

@ -52,7 +52,7 @@ define U-Boot/rock-pi-4-rk3399
BUILD_SUBTARGET:=armv8 BUILD_SUBTARGET:=armv8
NAME:=Rock Pi 4 NAME:=Rock Pi 4
BUILD_DEVICES:= \ BUILD_DEVICES:= \
radxa_rock-pi-4 radxa_rock-pi-4a
DEPENDS:=+PACKAGE_u-boot-rock-pi-4-rk3399:arm-trusted-firmware-rockchip DEPENDS:=+PACKAGE_u-boot-rock-pi-4-rk3399:arm-trusted-firmware-rockchip
PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip
ATF:=rk3399_bl31.elf ATF:=rk3399_bl31.elf

View File

@ -1,19 +0,0 @@
// SPDX-License-Identifier: (GPL-2.0+ OR MIT)
/*
* Copyright (c) 2019 Akash Gajjar <Akash_Gajjar@mentor.com>
* Copyright (c) 2019 Pragnesh Patel <Pragnesh_Patel@mentor.com>
*/
/* TODO
* Delete this file and migrate RockPi 4 to RockPi 4A after
* removing Kernel 5.4.
*/
/dts-v1/;
#include "rk3399-rock-pi-4.dtsi"
/ {
model = "Radxa ROCK Pi 4";
compatible = "radxa,rockpi4", "rockchip,rk3399";
};

View File

@ -32,12 +32,12 @@ define Device/pine64_rockpro64
endef endef
TARGET_DEVICES += pine64_rockpro64 TARGET_DEVICES += pine64_rockpro64
define Device/radxa_rock-pi-4 define Device/radxa_rock-pi-4a
DEVICE_VENDOR := Radxa DEVICE_VENDOR := Radxa
DEVICE_MODEL := ROCK Pi 4 DEVICE_MODEL := ROCK Pi 4A
SOC := rk3399 SOC := rk3399
SUPPORTED_DEVICES := radxa,rockpi4 SUPPORTED_DEVICES := radxa,rockpi4a radxa,rockpi4
UBOOT_DEVICE_NAME := rock-pi-4-rk3399 UBOOT_DEVICE_NAME := rock-pi-4-rk3399
IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
endef endef
TARGET_DEVICES += radxa_rock-pi-4 TARGET_DEVICES += radxa_rock-pi-4a

View File

@ -1,10 +0,0 @@
--- a/arch/arm64/boot/dts/rockchip/Makefile
+++ b/arch/arm64/boot/dts/rockchip/Makefile
@@ -36,6 +36,7 @@ dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-pi
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-puma-haikou.dtb
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-roc-pc.dtb
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-roc-pc-mezzanine.dtb
+dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-rock-pi-4.dtb
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-rock-pi-4a.dtb
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-rock-pi-4b.dtb
dtb-$(CONFIG_ARCH_ROCKCHIP) += rk3399-rock-pi-4c.dtb